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388

EXPLORING GENERATIVE AI

Lesson overview
In this lesson, you’ll learn how to do the following: 

• Create and enhance images using generative AI features.

• Refine the results of generative AI to get the image you want.

• Use different types of generative AI features in Photoshop.

• Understand how Adobe Firefly generative AI handles issues related 
to generative AI, such as rights and credits.

This lesson will take about 30 minutes to complete. To get the lesson files 
used in this chapter, download them from the web page for this book at 
peachpit.com/PhotoshopCIB2025. For more information, see “Accessing 
the lesson files and Web Edition” in the Getting Started  section at the 
beginning of this book.

As you work on this lesson, you’ll preserve the start files. If you need 
to restore the start files, download them from your Account page.

15
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Adobe Firefl y generative AI is built into Photoshop 
so that you can quickly explore visual ideas and 
create photorealistic or illustrative images simply by 
describing what you want.

PROJECT: BREAKFAST PROMOTIONPROJECT: BREAKFAST PROMOTION
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390 LESSON 15 Exploring Generative AI

About Adobe Firefly generative AI
The term artificial intelligence, or AI, isn’t new; you’ve probably been hearing it for 
years, and it’s been around for decades. For most of that time, AI has been about 
calculating results or analyses that seem unusually advanced. More recently, AI has 
been extended to include visual recognition such as being able to identify faces and 
read text in images.

Generative AI is much newer, and it’s called “generative” because it isn’t just about 
calculating or recognizing — it can create entirely new content. You saw this in 
Lesson 1 when you used Generative Fill to extend a photo into an empty area, con-
vincingly, in seconds. Traditionally, you’d do this kind of image extension by hand 
using a cloning tool to copy image content to the empty area, but there was always 
the risk of areas being obvious repetitions of something else in the image, and it 
took a significant amount of time. 

The ability of generative AI to seemingly invent completely new photorealistic 
images or write new text or music seems miraculous or magical, but in reality, 
generative AI only knows what to create based on its model of the problem and how 
well that model has been trained. Generative AI models are trained using very large 
sets of examples. Generative AI in Photoshop is trained on hundreds of millions of 
images. Because the quality of generative AI depends on its training, generative AI 
is constantly improving as the models are trained on more examples.

Generative AI is used not only in Photoshop but throughout many Adobe applica-
tions and services. For example, anyone can try generative AI in Adobe Express, a 
set of easy-to-use creative tools that work in a mobile app or web browser. Adobe 
gave their overall generative AI technology its own name, Adobe Firefly, and added 
Firefly capabilities into many of their applications including Photoshop.

There are some guidelines and restrictions for using Firefly generative AI; see  
www.adobe.com/legal/licenses-terms/adobe-gen-ai-user-guidelines.html.

How does Photoshop use generative AI?
Adobe Firefly generative AI is so useful that it appears in different forms throughout 
Photoshop so that it can help solve a range of challenges. You’ll find generative AI in 
places including:

Contextual Task Bar. After you create a selection marquee using any tool or 
method, the Contextual Task Bar offers a button such as Generative Fill or Generate 
Image; you learned this in Lesson 2. When the Contextual Task Bar is hidden or 
when the document context (such as the layer type selected in the Layers panel) 
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doesn’t display generative AI options, generative AI features are still available in 
other ways.

Edit menu. On the Edit menu, you’ll find the Generative Fill, Generate Image, and 
(in some versions) Generative Workspace commands. You’ll learn about all three of 
those later in this lesson.

Options bar. Some tools contain generative AI options. The Remove tool you tried 
in Lesson 2 has a Mode menu that includes generative AI options that can improve 
the results. In Lesson 5, you learned that the Crop tool has a Generative Expand 
option for filling empty areas created by cropping and straightening.

Many of these features didn’t exist a few years ago, and people are finding new uses 
for generative AI all the time. Don’t be surprised if there are even more generative 
AI features in Photoshop by the time you read this.

In earlier lessons, you used generative AI to repair or extend images. That use of 
generative AI is as a production tool to improve images you created or already have. 
Now it’s time to try using generative AI the other way: to create whole new images!

Getting started
You’ll use generative AI to complete a document that helps promote an earlier 
start time for breakfast service at a restaurant. The document needs to be easy to 
adapt for the different ways the restaurant wants to promote the service, so it’s been 
designed as a tall, narrow document so that it can easily be exported for posting on 
vertical format social media feeds, and it also matches a common size for an ad in a 
print publication.

1 Start Photoshop, and then simultaneously hold down Ctrl+Alt+Shift (Windows) 
or Command+Option+Shift (macOS) to restore the default preferences. (See 
“Restoring default preferences” on page 5.)

2 When prompted, click Yes to delete the Adobe Photoshop Settings file.

3 Choose File > Browse In Bridge to open Adobe Bridge.

4 In Bridge, click Lessons in the Favorites panel. Double-click the Lesson15 folder 
in the Content panel. 

5 Compare the files 15_Start.psd and 15_End.psd.

6 In Bridge, double-click the 15_Start.psd file to open it in Photoshop. If the 
Embedded Profile Mismatch dialog box appears, click OK.

7 Save the document as 15_Working.psd in the Lesson15 folder. If the Photoshop 
Format Options dialog box appears, click OK.

• Note: If Bridge 
isn’t installed, the 
File > Browse In Bridge 
command in Photoshop 
will start the Creative 
Cloud desktop app, 
which will download 
and install Bridge. After 
installation completes, 
you can start Bridge. 
For more information, 
see page 3.

• Note: If Photoshop 
displays a dialog box 
telling you about the 
difference between 
 saving to Cloud 
Documents and 
On Your Computer, click 
Save On Your Computer. 
You can also select 
Don’t Show Again, 
but that setting will 
deselect after you reset 
Photoshop preferences.
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Generating a complete image
In earlier lessons, you used generative AI to enhance existing images. Another 
popular use of generative AI is to create entirely new images. Th e 15_Start.psd 
document needs an appealing image of a breakfast.

You do have to think about how appropriate generative AI is for the project you’re 
working on. Th is project promotes a general breakfast service and not a specifi c 
named dish, so a generative AI image may be acceptable; but always check with the 
client. If the promotion was about a specifi c item on the menu, it would be much 
better to commission a photograph of what that menu item actually looks like.

Th e lesson fi le has two layers. Th e bottom layer, Gradient Fill, is a radial  gradient 
that goes from transparent in the center to black at the edge. If you want to 
inspect how it’s set up, in the Layers panel select the Gradient Fill layer, and then 

• Note: The examples 
of generative AI images 
in this lesson may diff er 
from the results you 
get, in part because, 
over time, Adobe Firefl y 
generative AI is likely to 
be updated and trained 
with more images to 
improve the results.
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in the Tools panel select the Gradient tool so that the Properties panel displays 
Gradient Adjustment options. Th e gradient is transparent in the center so that after 
you generate an image and move it to the bottom of the layer stack, you’ll be able to 
see the image through the gradient.

Th e top layer, Breakfast Ad Text, was created in Photoshop as a separate document 
and saved as a Photoshop PDF to maintain its vector outlines. It was then brought 
into this lesson fi le using the File > Place Embedded command, which adds it to the 
Layers panel as an embedded Smart Object.

If the document contained a pixel layer and it was selected, the Contextual Task Bar 
might off er a Generate Image button. Neither of the existing layers is a pixel layer 
(one is an embedded Smart Object layer and the other is a gradient fi ll layer), but 
that’s not a problem; you can still use generative AI from the Edit menu.

1 Choose Edit > Generate Image.

2 In the Generate Image dialog box, click in the “Describe…” prompt box, type 
healthy breakfast to describe the image for it to generate, and then click 
Generate. If a message appears asking you to read and agree to the Generative 
AI User Guidelines, click Agree when you’re ready.

▶ Tip: Because the 
vector text outlines in 
the Breakfast Ad Text 
layer are preserved in 
Photoshop PDF format, 
the text edges remain 
smooth if you scale up 
that Smart Object layer.

▶ Tip: The prompt 
in step 2 uses just two 
words, but it’s common 
for a prompt to use 
more words to get the 
image you want.
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Generating images may take some time. When it fi nishes, you’ll see that:

• On the canvas, the empty selection is replaced with new content.

• In the Layers panel, a new Generative Layer was created, and the name of the 
layer is the prompt you entered.

• In the Properties panel, as long as a generative layer is selected, a Variations 
section off ers alternatives you can click to try. Th e selected variation is the 
one you see on the canvas.

3 In the Layers panel, 
drag the Healthy 
Breakfast layer to the 
bottom of the layer 
stack so that you 
can see the design 
working as intended, 
showing the text and 
radial gradient in 
front of the image.

• Note: If you don’t 
see the Variations 
section, it may be out 
of view, especially on 
a smaller display. Try 
scrolling the Properties 
panel to bring the 
Variations panel up and 
into view.

Sam
ple



ADOBE PHOTOSHOP CLASSROOM IN A BOOK 2025 RELEASE 395

4 In the Variations section of the Properties panel, click the other variations in 
turn, and leave selected the variation you think is the best.

5 Save the document.

Refi ning a generative layer
It’s common for the fi rst results of a prompt to be too far from the image you actu-
ally want. Photoshop off ers ways to make the results closer to what you want.

1 In the Variations section of the Properties panel, 
hover over the fi rst variation and click the 
ellipsis (…) menu. You don’t have to click any of 
the options, but note what they are:

• Generate Similar creates another set of 
variations for the same prompt.

• Remove Background attempts to isolate the subject and erase the back ground. 
However, manually selecting and removing the background might work better.

• Good, Poor, and Report don’t change the current variation but are a way of 
providing feedback to Adobe about the quality of the results of generative AI.

▶ Tip: Variations 
are saved with the 
document, so if you 
think the document 
fi le size is too large, 
delete any variations 
you are sure you don’t 
want to keep.
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Another way to change the results is to change the prompt.

2 In the Properties panel, click in the Prompt 
box, enter a variation on “healthy breakfast” 
by adding descriptive words, click Generate, 
and select the variation you like the most. We 
entered healthy breakfast with pancakes 
and blueberries.

So far the variations are photorealistic. Next 
you’ll choose a more illustrative style that you 
can customize.

3 Click the second icon below the Prompt box 
to open style options, select Art, and select 
a specifi c look from the Eff ects category. We 
clicked All, and then selected Art Deco.

4 Click Generate and select the variation that works best with the design.

▶ Tip: The Enter 
or Return key is a 
shortcut for clicking 
the Generate button.
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5 Click the fi rst icon below the Prompt box to open Reference Image options. 
Select one of the images (we selected the fi rst one), click Generate, and select 
the variation you like the most. Th ese results were infl uenced by the style of the 
reference image you selected.

How is Reference Image diff erent than the Eff ects? Selecting a reference image is a 
way for you to infl uence variations using any image. Th e images in the Gallery are 
simply examples, but a great use of Reference Image is for generating art based on 
your personal style. To do this, open Reference Image options, click the Replace 
Image button, and select an image that represents your style. Of course, you can also 
use Reference Image to generate art based on a style you want to emulate, such as a 
client’s style.

Take a look at the icons for Reference Image and Style Eff ects and remember them, 
because they appear in other places in Photoshop where you can use generative AI. 
For example, those options are also available on the Contextual Task Bar for genera-
tive fi ll and in the Generative Workspace dialog box (see the sidebar “Save time with 
Generative Workspace” on page 399).
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6 Feel free to continue to explore 
Firefl y generative AI. 

For 15_End.psd, we went with one 
of the photographic variations. 
Don’t expect to match our results 
exactly because the Firefl y model 
and training may change over time. 
Just create and select a variation 
that you think works the best for 
the promotional image.

7 When you’re done, save and close 
the document.

Th e document is now ready to save 
or export copies for various media 
using workfl ows you’ve learned in 
earlier lessons, such as exporting 
for the web, printing on your own 
printer, or exporting for a print 
 service provider.

About generative credits
Generative AI requires signifi cant computing power. Sometimes it can all be 
done on your computer. Other times, the fastest way to generate the results is for 
Photoshop to send the prompt and image to Adobe Firefl y on a Creative Cloud 
server where the results are generated using a much more powerful computer, and 
then on your computer, Photoshop receives the results and integrates them with 
your Photoshop document.

It takes a lot of cloud computing power to run generative AI, so Adobe came up 
with a system to manage server usage called Generative Credits. Creative Cloud 
members receive a certain number of Generative Credits every month. Th e number 
of credits you get depends on the Creative Cloud plan used by you or your school 
or organization. If you run out of Generative Credits before the end of a month, you 
can continue to use Generative Fill, but it may run more slowly because your jobs 
will have a lower priority. If you need to restore performance priority, it’s possible 
to purchase more credits. For more information, including how to see the number 
of generative credits you have in the current month, see helpx.adobe.com/fi refl y/
using/generative-credits-faq.html.

Adobe continues to work out how to best provide generative AI services, so 
Generative Credits policies may change or improve over time. 

• Note: At the time 
this lesson is being 
written, the maximum 
pixel dimensions 
of a generative AI 
image in Photoshop 
is 2000 × 2000 pixels. 
If you use generative 
AI on larger areas, the 
2000 × 2000 pixel result 
will be scaled up.
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