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W O R K S H O P S

Learn to select and 
tend flowers that 
attract hummingbirds, 
flourish in our 
climate, and create 
fabulous flowerbeds. 
Create your own 
nectary to attract 
birds to your feeder 
on patio or balcony.

Free 
Workshop 

Series!

Create a Hummingbird Habitat

Entrées & Desserts
Indulge in our chef’s 
daily creations, such as 
lavender honey grilled 
chicken or fresh basil 
pesto (V) and be sure to 
leave room for scrump-
tious violet macarons or 
candied pansies (V, GF).

Starters & Small Plates
Sip a rosé martini, try 
zucchini blossom fritters 
(V) or braised dandelion 
greens (V, GF) for appe-
tizers, and share small 
plates such as orange 
ginger seared scallops or 
chive flower flatbread.

edible 
blossoms
Bistro & Bar
Relax in our elegant dining room or charming patio and 
enjoy the creations of our bartender, chef and gardener! 
Our irresistible appetizers, seasonal entrées and home-
made desserts feature fruits, flowers and herbs grown 
right here in our stunning Urban Oasis Gardens.

blossomsblossomsblossomsblossomsblossomsblossomsblossoms

See the full menu!

Sam
ple



vi CONTENTS

3 SETTING UP A DOCUMENT AND WORKING WITH PAGES 56

Getting started . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 58

Creating a new document . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 59

Creating and saving custom document settings  . . . . . . . . . . . . 60

Creating a new document from a preset . . . . . . . . . . . . . . . . . . . . 61

Working with parent pages  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 62

Applying parent pages to document pages . . . . . . . . . . . . . . . . . 71

Adding new document pages . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 72

Rearranging and deleting document pages . . . . . . . . . . . . . . . . . 72

Changing the size of pages within one 
InDesign document . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 73

Adding sections to change page numbering . . . . . . . . . . . . . . . . 74

Printing to the edge of the paper: Using the bleed guides . . . 79

Rotating spreads for easier editing . . . . . . . . . . . . . . . . . . . . . . . . . 81

Exploring on your own . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 83

4 WORKING WITH OBJECTS 86

Getting started . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 88

Introducing layers  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 89

Working with layers . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 92

Transforming the shape of frames . . . . . . . . . . . . . . . . . . . . . . . . . . 95

Creating and modifying graphics frames  . . . . . . . . . . . . . . . . . . . 99

Adding metadata captions to graphics frames . . . . . . . . . . . . . 105

Wrapping text around a graphic . . . . . . . . . . . . . . . . . . . . . . . . . . .108

Transforming and aligning objects  . . . . . . . . . . . . . . . . . . . . . . . .110

Selecting and modifying grouped objects . . . . . . . . . . . . . . . . .118

Flowing type along a path  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .119

Drawing lines and adding arrowheads . . . . . . . . . . . . . . . . . . . . .120

Exploring on your own . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 123

2 GARDEN NEWS

Urban Oasis Garden

Bees and Bugs

Pollinators and Predators
Pollinators obtain food in the form of energy-rich nectar and/or pro-
tein-rich pollen from the flowers they visit. In return, the pollinated 
flowers are able to develop and produce seed. While food is often a suffi-
cient lure for pollinators, flowering plants also attract pollinators using a 
combination of shape, scent, and/or color. For example, some plants use 
mimicry to deceive animals into visiting their flowers without having to 
provide a reward.
Predators rid the garden of insects and larvae that are harmful to plants. 
The most widely known beneficial beetles are the pretty little ladybugs. 
Their shining rounded wing-cases, and bright colors make them con-
spicuous objects. The ones most commonly noticed are red, spotted 
with black. Quietly and silently they perform the work of extermination 
before our eyes, their worth entirely unheeded.
The elongated ground-beetle, is a carnivorous beetle. Its color is shining 
black, bordered with deep blue. It is often met with in our gardens, and 
preys indiscriminately upon all soft-bodied larvae — especially upon the 
larvae of the Colorado Potato-beetle.
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How to grow  
peas, please!

Plant: May
Soil: Moist
Fertilizer: Dairy 
dressing
Sow: 5” deep
Thin: 1” apart
Pick: August Peas grow well in heavy, moist 

soil that is not suitable for some 
other vegetables. However, the land 
for peas, as for all vegetable plants, 
should be drained and free from 
standing water. Nothing is quite so 
good as dairy dressing for peas, and 
it is worthwhile to get it if possible.

Fertilizing
When dairy dressing is at hand, be 
sure the ground is soft and fine; then 
open furrows about eight inches 
deep. These should be three feet apart 
for the Nott’s Excelsior type, and 

four feet for the climbing types. Into 
these furrows throw a liberal layer of 
dairy dressing to cover the bottom 
of the furrow. If you can spare it, put 
in a wheelbarrow load to twenty feet 
since peas are great feeders and need 
nourishment during the hot days of 
July when the crop is ripening. 

Here is one case where dairy 
dressing may be used that is rather 
fresh, as peas seem to do well with 
dairy dressing at any stage. Stable 
dressing, which contains straw and 
horse manure, is more likely to de-
velop heat, which will hurt the seed; 

Peas continued on 2

Peas are easy to grow, but once 
they pop up they need a little 
protection. A little daily atten-

tion will ensure an awesome crop 
and a supply of nutritious side dishes 
and snacks. Enjoy the fresh air and 
satisfaction of gardening during the 
day and peruse your cookbooks for 
ideas at night. Next month, we’ll have 
plenty of great recipes for you to try.

Cover. Cover peas gradually as 
they grow. In using dairy dressing, 
the furrow is opened deep enough to 
allow for manure well below the peas. 
Of course this deep furrow is not 
necessary when fertilizers are worked 
into the soil. In that case, the furrow is 
opened to a depth of only about 4 or 5 
inches. In either case, 2 inches of earth 
is drawn over the peas when first 
planted, leaving another 1 or 2 inches 
of earth to draw about them after they 
have grown 5 or 6 inches high.

Thinning Out. When the peas are 
up 1 inch or so, it is time to thin them 
out. Crowding is responsible for many 
poor crops of peas. Thin out the dwarf 
peas so that they stand about 1 inch 
apart, and the tall ones so that they 
stand about 1.5 inches apart. Pull out 
the weaker sprouts first. TIP: It may 
take some courage to thin them out, 
but it pays off in the end.

Protection from Blackbirds. 
Blackbirds are fond of pea vines when 
they are young and tender. Sometimes 

they will nip off the sprouts and spoil 
a long row in one early breakfast. A 
white string, stretched above the row, 
with white rags tied here and there, 
will usually keep them away. Small 
flags, made by tying a strip of white 
cotton cloth to a stick will serve well 
also. TIP: If there are many blackbirds 
about, it is a wise gardener who takes 
this easy precaution. It is a little too 
late after the blackbirds have been 
there.

Caring for the Vines. The dwarf 
peas need no further care, except 
cultivation to keep the earth soft and 
free from weeds. The blossoms form 
in about four weeks, and the peas 
ripen quickly after that. The season for 
peas begins early in May, and they are 
picked in August along the northern 
belt. Because of its fondness for cool 
climates and moist earth, the pea is 
most delicious and profitable in those 
states where the summer days are not 
extremely hot.

Picking Peas. It does not pay to 
pick peas before they are fairly well 
filled out, as they are wasted in that 

way. You can soon learn to tell, by a 
gentle pressure of the thumb near the 
lower end of the pod, whether the 
peas are large enough to pick. On the 
other hand, it is unwise to leave them 
on the vines to dry, as that will tend to 
check the growth of the peas form-
ing at the top of the vine. In taking 
the pod from the vines, be careful to 
use both hands. Hold the vine with 
one hand just above the pea, to save 
the tender branches from being torn. 
TIP: Remember the new peas which 
are coming above those you are pick-
ing, and give them a free chance to 
mature.

Follow Crops. As soon as the 
crop of peas is harvested, pull out the 
vines, put away the supports you wish 
to save for the next season, and dig 
over the ground for a crop of some-
thing else. Bush string beans, turnips, 
cabbage, winter beets, lettuce, and 
other quick growing plants may be 
put in the same rows. 

Recipes. Next month look for 
recipes for Soupe Aux Pois (Pea 
Soup), Balsamic Pea Salad, Lemon 
Orzo with Peas, Fregola with Peas and 
Ricotta, and Peas with Pancetta.

Source. “Protecting Your Peas” 
excerpted from Garden Steps: A 
Manual for the Amateur in Vegetable 
Gardening, by Ernest Cobb, 1917.

peas
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A BITE OF DELIGHT

Chocolate-Covered Strawberries

½ lb strawberries with stems
½ cup chocolate chips
1/4 cup sprinkles 
1. Wash the strawberries.
2. Melt chocolate in the 

microwave in 30-second 
bursts; stir in between.

3. Dip the strawberries in 
the chocolate, and then in 
the sprinkles.

4. Place on wax paper to 
set, about 30 minutes.

Nutritional Facts

Serving Size . . . . . . . . . . . . . . 6
Calories  . . . . . . . . . . . . . . . 280
Calories from Fat . . . . . . .35%
Protein . . . . . . . . . . . . . . . . . 0g

Heart-shaped fruit that’s good for your heart? Check. 
Fruit that can boost your immunity, lower your cho-

lesterol, protect your vision, prevent cancer (and wrin-
kles!) and help with weight management? Check. Vitamin 
C and vitamin K? Check, check. And on top of all that, 
strawberries are easy to grow. 

Plant your strawberries in the full sun, 12 to 18 inches 
apart. Cover the roots, keep the central growing bud at 
soil level, and use a balanced fertilizer. In the sg, add com-
post and fertilizer, and then in fall mulch with straw. As 
your strawberries grow, keep them moist and weeded. As 
strawberries begin to ripen, cover them with lightweight 
netting to keep the birds at bay.   

Pick strawberries when they’re cool and refrigerate 
them immediately. Wash before use and enjoy! Your yo-
gurt, pancakes, shortcakes and more are waiting.

“You stand 
out like  

a strawberry 
in a bowl  
of peas.”

Strawberries

••

Premium Vegetable Seeds, Starter Plants & Tools
Grow your best garden yet with Urban Oasis Gardens. Our experts have selected a wide 
variety of vegetables, flowers and fruit that fit our growing zone. We guarantee our 
seeds, bulbs and starters plants will bring a bumper crop while brightening your 
garden. Plus, we offer gardening tools that make your toughest tasks easier. 

Start dreaming and planning, and then get your orders in just in time for growing 
season. As always, Urban Oasis Gardens offers various courses to ensure your 
gardening success.

Heirloom Vegetable Seeds

Look for your tried-and-true favorites and the rare varieties you love. We offer seeds and some 
starter plants for everything from carrots and cucumbers to peas and peppers to watermelon rad-

ishes. Our heirloom seeds are organic, non-GMO and time tested. 

Fruits & Flowers
Whether it’s English, Japanese, tropical or wildflower, your dream garden awaits with Urban Oasis 
Gardens. Start with your favorite color and design for constant color and interest as the seasons change. We 

can put your favorite fruit at your fingertips as well with our fast-growing trees. Home-grown 
fruits last longer and cost far less than store-bought.  

Tools & Accessories
The right tool for the job ensures that your gardening efforts are not wasted. Urban 
Oasis Gardens offers high-quality, durable, sustainable rakes, shovels, pruners, 

tillers, trowels and more. Garden tool sets help gardeners-to-be get started at a great 
price. Your plants won’t go hungry with our superior selection of organic fertilizers, and 
our expert sprayers and spreaders help with proper application.

FA B U L O U S  F L O W E R  T I P S
What Where to Plant What to Watch For
Sunflower Sunny, sheltered soil Support stems for taller flowers

Marigold Sunny, fertile soil Plant around tomatosto prevent flies

Pansy Sun or dappled shade Deadhead to encourage more blooms

Sweet Pea Sunny spot, support Protect from mice

Urban Oasis Gardens

 Indicates off-site activity. 1

DAILY DROP-IN ACTIVITIES

ACTIVITY DAY TIME FEE

Attracting Butterflies Su 8–10 a.m. $10

Illustrating Botanicals M noon–2 p.m. $25

Creating Garden Flags T 10 a.m.–2 p.m. $25

Making Hummingbird Feeders W 2–5 p.m. $50

Tending Flowers Th 9–11 a.m. $10

Growing Edible Flowers F 1–3 p.m. $10

Making and Flying Kites Sa 8–11 a.m. Free

Urban Oasis 
Gardens Summer ScheduleSam
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GETTING TO KNOW INDESIGN

Lesson overview
In this lesson, you’ll learn how to do the following: 

•	 View layout aids.

•	 Type and style text.

•	 Import text and thread text frames.

•	 Import a graphic. 

•	 Use AI to add a graphic based on a prompt. 

•	 Move, rotate, fill, and stroke (outline) an object.

•	 Add a QR code. 

•	 Automate formatting with paragraph, character, and object styles.

•	 Check on potential production issues with the Preflight panel.

•	 Preview a document in Presentation mode.

This lesson will take about 60 minutes to complete. To get the lesson files 
used in this chapter, download them from the web page for this book at 
peachpit.com/InDesignCIB2025. For more information, see “Accessing the 
lesson files and Web Edition” in the Getting Started section at the begin-
ning of this book.

2

Sam
ple

http://peachpit.com/InDesignCIB2025


35

Entrées & Desserts
Indulge in our chef’s 
daily creations, such as 
lavender honey grilled 
chicken or fresh basil 
pesto (V) and be sure to 
leave room for scrump-
tious violet macarons or 
candied pansies (V, GF).

Starters & Small Plates
Sip a rosé martini, try 
zucchini blossom fritters 
(V) or braised dandelion 
greens (V, GF) for appe-
tizers, and share small 
plates such as orange 
ginger seared scallops or 
chive flower flatbread.

edible 
blossoms
Bistro & Bar
Relax in our elegant dining room or charming patio and 
enjoy the creations of our bartender, chef and gardener! 
Our irresistible appetizers, seasonal entrées and home-
made desserts feature fruits, flowers and herbs grown 
right here in our stunning Urban Oasis Gardens.

blossomsblossomsblossomsblossomsblossomsblossomsblossoms

See the full menu!

The building blocks of an Adobe InDesign layout are 
objects, text, and graphics. Layout aids such as guides 
help with size and placement, and styles let you 
format page elements automatically. 

Sam
ple



36 LESSON 2 Getting to Know InDesign

Getting started
Th e document for this lesson is a standard-size postcard designed to be printed and 
mailed. In addition, the postcard can be exported as a JPEG to use in email market-
ing and social media. Th e postcard is landscape orientation, but it can be converted 
to a portrait layout for other media via the InDesign Create Alternate Layout feature 
or the Liquid Layout feature (both found in the Layout menu). As you will see in 
this lesson, the building blocks of an InDesign document are essentially the same, 
regardless of the output media. In this lesson, you will add the text, images, and 
formatting necessary to fi nish the postcard. 

1 To ensure that the preferences and default settings of your Adobe InDesign 
program match those used in this lesson, move the InDesign Defaults fi le to a 
diff erent folder following the procedure in “Saving and restoring the InDesign 
Defaults fi le” on page 4. 

2 Start InDesign. 

3 When the InDesign Home screen displays, click the Open button at the left. 
(If the Home screen does not display, choose File > Open from the InDesign 
menu bar.) 

4 Open the 02_Start.indd fi le in the Lesson02 folder, located inside the Lessons 
folder within the InDesignCIB folder on your hard drive. 

5 If an alert informs you that the document contains links to sources that have been 
modifi ed, click Update Modifi ed Links.

6 Choose File > Save As, rename the fi le 02_Postcard.indd, and save it in the 
Lesson02 folder. 

7 Th is lesson uses the default Essentials workspace. If necessary, choose 
Window > Workspace > [Essentials], and then choose Window > Workspace > 
Reset Essentials. 

8 If you want to see what the 
fi nished document looks like, 
open the 02_End.indd fi le in 
the same folder. (Note that 
your fi nal document may look 
slightly diff erent due to 
varying Text To Image AI 
results.) You can leave this 
document open to act as a 
guide as you work. 

9 When you’re ready to resume 
working on the lesson document, display it by clicking its tab in the upper-left 
corner of the document window.

• Note: If you have 
not already downloaded 
the project fi les for 
this lesson to your 
computer from your 
Account page, make 
sure to do so now. See 
“Getting Started” at the 
beginning of the book.

• Note: To better view 
the interface onscreen 
or in print, the screen 
captures in this book 
refl ect the Medium 
Light interface rather 
than the default setting 
of Medium Dark. In 
addition, some screen 
captures illustrate 
User Interface Scaling 
for a closer look at 
interface elements. You 
can modify interface 
settings in Preferences.

Entrées & Desserts
Indulge in our chef’s 
daily creations, such as 
lavender honey grilled 
chicken or fresh basil 
pesto (V) and be sure to 
leave room for scrump-
tious violet macarons or 
candied pansies (V, GF).

Starters & Small Plates
Sip a rosé martini, try 
zucchini blossom fritters 
(V) or braised dandelion 
greens (V, GF) for appe-
tizers, and share small 
plates such as orange 
ginger seared scallops or 
chive flower flatbread.

edible 
blossoms
Bistro & Bar
Relax in our elegant dining room or charming patio and 
enjoy the creations of our bartender, chef and gardener! 
Our irresistible appetizers, seasonal entrées and home-
made desserts feature fruits, flowers and herbs grown 
right here in our stunning Urban Oasis Gardens.

blossomsblossomsblossomsblossomsblossomsblossomsblossoms

See the full menu!
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Viewing guides
Revising or completing an existing document, as you will do in this lesson, is typical 
work for entry-level InDesign users. Currently, the postcard document is displayed 
in Preview mode, which displays artwork in a standard window, hiding nonprinting 
elements such as guides, grids, frame edges, and hidden characters. To work on this 
document, you will view guides and hidden characters (such as spaces and tabs). 

1	 Click and hold down the Screen Mode button  
at the bottom of the Tools panel, and choose 
Normal ( ) from the menu. 

Any layout aids previously turned on now display. 
For example, light blue nonprinting lines now 
indicate existing text frames and objects because 
frame edges were already displayed (View > 
Extras > Show Frame Edges). You will now  
enable other layout aids. 

2	 Choose View > Grids & Guides > Show Guides. 

When guides are displayed, it’s easy to position objects with precision, including 
automatically snapping text frames and graphics frames into place. The guides 
do not print and do not indicate the print or export area. 

3	 Choose Type > Show Hidden Characters. 

Displaying hidden (nonprinting) characters—such as tabs, spaces, and paragraph 
returns—helps you precisely select and style text. In general, it’s a good idea to 
show hidden characters whenever you are editing or formatting text.

Margin guide (magenta)

Ruler guide (blue)

Page edge

Paragraph return  
hidden character

Space hidden character 
(dot)

Forced line break  
hidden character

4	 As you work on this document, use the skills you learned in Lesson 1 to move 
panels, scroll, and zoom as necessary.

▶▶ Tip:  The lesson 
document starts out in 
Preview Mode and then 
you switch to Normal 
Mode. The other modes 
are Bleed, for reviewing 
the predefined bleed 
area for objects that 
extend beyond the 
page boundaries; Slug, 
for displaying the area 
outside the bleed 
area that can contain 
information such as 
printer instructions; and 
Presentation, which fills 
the screen and works 
well for presenting 
design ideas to clients. 

▶▶ Tip:  As you become 
comfortable working 
with InDesign, you will 
discover which screen 
modes and layout aids 
work best for you.

Text frame edge
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Adding text
With InDesign, most text is contained in a text frame. (Text can be contained in 
table cells and flow along paths as well.) You can type text directly into a text frame 
or import text files from word-processing programs. When importing text files, you 
can add the text to existing frames or create new frames to contain the text. If text 
doesn’t fit within a single frame, you can link multiple text frames using a process 
called “threading.” You will learn more about flowing text, including dividing text 
frames into columns, in Lesson 6, “Flowing Text.” 

Typing and styling text
You’re ready to start working on the incomplete postcard. To get started, you’ll edit 
and style the text under the main headline. 

1	 Select the Type tool ( ), and click immediately after the word “Café.” 

2	 Press Backspace (Windows) or Delete (macOS) four times to delete the 
word “Café.”

3	 Type Bistro in the text frame so that the restaurant’s descriptor is changed from 
“Café & Bar” to “Bistro & Bar.”

 

4	 With the insertion point still in the text, triple-click to select “Bistro & Bar.” 

5	 Locate the Character controls of the Properties panel at the right. From the Font 
Style menu, select Bold.

 

▶▶ Tip:  Use the Type 
tool to edit text, format 
text, and create new 
text frames.

▶▶ Tip:  When you enter 
edits, consider copying 
and pasting text from 
the notes in Acrobat or 
InDesign to ensure that 
you don’t introduce 
typographical errors.

▶▶ Tip:  When you apply 
bold or italic formatting 
in InDesign, you are 
actually applying a 
variation of the font, 
which you select from 
a menu. Depending on 
the font, you may have 
various choices such as 
extra bold or bold italic. 
As a result, InDesign 
and other professional 
publishing applications 
do not provide a simple 
bold or italic button for 
applying these styles.  
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6	 Click outside the text frame to deselect the text. 

7	 Choose File > Save to save your work.

Options for styling and  
placing text
In the Essentials workspace, the Properties panel displays at the right to provide 
quick access to the most common text formatting options. InDesign provides other 
options for formatting characters and paragraphs and for positioning text within a 
frame. Common text formatting options include:

•	 Character formats: Style, Size, Leading (line spacing), All Caps

•	 Paragraph formats: Alignments such as Center, Indents, Space Before/After

•	 Text Frame Options: Columns, Inset Spacing, Vertical Justification

The Control panel, Paragraph panel (Type > Paragraph), and Character panel (Type > 
Character) provide all the controls you need to style text. To control the positioning 
of the text within its frame, such as dividing text into columns, choose Object > Text 
Frame Options. Many of these styling options also are available in the Control panel 
(Window > Control or Window > Workspace > Advanced).

Importing and flowing text
In most publishing workflows, writers and editors use word processors. When the 
text is almost final, they send the files to graphic designers. To complete the postcard, 
you will import a Microsoft Word file into a text frame at the bottom of the page 
using the Place command. You will then thread (link) the first text frame to the 
second frame. All the text in a series of threaded text frames is called a “story.” 

1	 Using the Selection tool ( ), click a blank area of the pasteboard to make sure no 
objects are selected. (Scroll to the right or left as needed to see the pasteboard.)

2	 Choose File > Place. At the bottom of the Place dialog, make sure that Show 
Import Options is not selected. (On macOS, click Options if necessary to see 
Show Import Options.)

3	 Navigate to the Lesson02 folder in the Lessons folder, and double-click the 
Bistro.docx file.

The pointer changes to a loaded text icon ( ). You’ll add this text to the text 
frame in the lower-left quadrant of the postcard. (The text frames are outlined 
by light blue nonprinting lines.)

• Note:  To see  
where to place the  
text, view the finished 
lesson document, 
02_End.indd. 
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4	 Position the loaded text icon in the text frame, and then click. 

An out port on the text 
frame; the red plus sign 
indicates overset text. 

The text in the Word file fills the frame, but it may not all fit. A red plus sign (+) in 
the out port of the frame (in the frame’s lower-right corner) indicates overset text. 
You will thread the two bottom text frames so that the text flows through them. 

5	 Using the Selection tool, select the text frame that now contains the text. 

6	 Click the out port (+) of the selected frame to display the loaded text icon. Click 
in the text frame immediately to the right. 

▶▶ Tip:  When the 
loaded text icon is 
displayed, you have 
several choices: You can 
drag to create a new 
text frame, click inside 
an existing frame, or 
click to create a new 
text frame within the 
page’s column guides.

▶▶ Tip:  You can create 
columns by threading 
individual text frames or 
by dividing text frames 
into multiple columns 
using the General tab of 
the Text Frame Options 
dialog (Object menu). 
Some designers prefer 
to create columns using 
separate text frames for 
more layout flexibility. 
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At this point, text likely remains overset. You will resolve this problem by 
formatting the text with styles later in this lesson. 

7 Choose File > Save.

Working with styles
InDesign provides paragraph styles, character styles, and object styles for quickly 
and consistently formatting text and objects. Another signifi cant reason to use styles 
is that you can make global changes—such as changing the body text font or adjust-
ing drop shadows—by simply editing the style. Th is can save you hours in making 
revisions to long documents such as books. Styles work as follows:

• A paragraph style includes all text formatting attributes—such as font, size, and 
alignment—and it applies to all the text in a paragraph. You can select a paragraph 
for formatting by clicking in it, highlighting any part of it, or highlighting all of it.

• A character style includes only character attributes—such as font style (bold or 
italic) and color—and it applies only to selected text within a paragraph. Character 
styles are generally applied to call attention to specifi c text within a paragraph.

• An object style lets you apply formatting—such as fi ll and stroke color, stroke 
styles and corner eff ects, transparency, drop shadows, feathering, text frame 
options, and text wrap—to selected objects.

Paragraph styles specify for-
mats such as alignment and 
basic character formats such 
as font and line spacing. 

Entrées & Desserts
Indulge in our chef’s 
daily creations, such as 
lavender honey grilled 
chicken or fresh basil 
pesto (V) and be sure to 
leave room for scrump-
tious violet macarons or 
candied pansies (V, GF).

Starters & Small Plates
Sip a rosé martini, try 
zucchini blossom fritters 
(V) or braised dandelion 
greens (V, GF) for appe-
tizers, and share small 
plates such as orange 
ginger seared scallops or 
chive flower flatbread.

edible 
blossoms
Bistro & Bar
Relax in our elegant dining room or charming patio and 
enjoy the creations of our bartender, chef and gardener! 
Our irresistible appetizers, seasonal entrées and home-
made desserts feature fruits, flowers and herbs grown 
right here in our stunning Urban Oasis Gardens.

Character styles specify 
variations from the 
character formats in 
the paragraph style. 

The object style for this 
text frame specifi es the 
inset (that indents the 
text from the edges of 
the frame), the stroke 
around the edges of 
the frame, and the 
drop shadow behind it. 

• Note: Due to 
variations in font 
versions, you may see 
slightly diff erent text 
in your frames. 

▶▶ Tip: A paragraph 
style can include 
nested styles that 
format the beginning 
of a paragraph and lines 
within a paragraph. This 
automates common 
paragraph formatting, 
such as starting a para-
graph with a drop cap 
followed by all capital 
letters on the fi rst line. Sam
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Applying paragraph styles
Because the postcard is part of a series, all the paragraph styles you need are already 
created. You will first apply the Body Copy style to all the text in the two threaded 
text frames, and then you will apply the Subhead style to the headings. 

1	 Using the Type tool  
( ), click in one of  
the text frames 
containing the newly 
imported text. 

2	 Choose Edit > Select  
All to select all the  
text in the story. 

3	 Click the Paragraph 
Styles button at the  
top of the Properties 
panel. Click the Paragraph Styles menu and select the Body Copy style to format 
the entire story.

4	 Using the Type tool, click in the first line of text in the story: “Starters & 
Small Plates.” 

As you can see from the hidden character (the paragraph return) at the end of 
the line, this line is actually its own paragraph. Therefore, it can be formatted 
with a paragraph style. 

5	 Select the Subhead style from the Paragraph Styles menu in the Properties panel.

6	 Apply the Subhead paragraph style to the “Entrées & Desserts” subhead as well. 

7	 Choose Edit > Deselect All, and then choose File > Save. (The Deselect All 
command is about halfway down the Edit menu.)

Formatting text for the character style
Highlighting key words in a paragraph can draw readers into the text. For the post-
card copy, you will format the abbreviations for vegetarian foods (V) and gluten-
free foods (GF) to make them “pop” and then create a character style based on that 
formatting. You can then quickly apply the character style to other selected words. 

1	 Using the Zoom tool ( ), zoom in on the first text frame in the lower-
left quadrant of the postcard. This frame contains the subhead “Starters & 
Small Plates.”

2	 Using the Type tool ( ), select the “(V)” in the first paragraph of body copy;  
be sure to select both parentheses as well.

▶▶ Tip:  In many pub-
lishing environments, 
including marketing 
and advertising, the 
text in a publication 
is referred to as “copy,” 
which is why the writers 
and editors are called 
“copywriters” and 
“copyeditors.” 

• Note:  If a plus sign 
(+) displays next to the 
applied style (Body 
Copy or Subhead), 
it indicates that the 
text formatting does 
not precisely match 
the style’s formatting. 
To resolve this, click 
Clear Overrides  ( )
at the bottom of the 
Paragraph Styles panel. 
You will learn more 
about styles in Lesson 9, 
“Working with Styles.” Sam
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3	 In the Character controls of the Properties panel at the right, select Italic from 
the Type Style menu. 

4	 Click the Fill box ( ) to display the document’s color swatches. Click the red 
swatch named Red-Bright to apply the color to the text.

5	 Click the pasteboard to deselect the text and view your changes. 

6	 Choose File > Save.

Creating and applying a character style
Now that you have formatted the text, you are ready to create a character style based 
on that formatting.

1	 Using the Type tool ( ), select the newly formatted “(V).”

2	 Choose Type > Character Styles to display the Character Styles panel.

3	 Select New Character Style from the panel menu ( ). 

The New Character Style dialog opens with a new style named Character Style 1. 
This new style includes the characteristics of the selected text, as indicated in the 
Style Settings area of the dialog.

4	 In the Style Name field, replace the default name (Character Style 1) with  
Red Italic.

▶▶ Tip:  Using the Type 
tool, you can double-
click to select a word, 
triple-click to select a 
line, and click four times 
to select a paragraph.

• Note:  If the  
New Character Style 
dialog does not open 
immediately, double-
click Character Style 1 
in the Character 
Styles panel. 
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5	 Below the Style Settings in the New Character Style dialog, select Apply Style 
To Selection. 

6	 Click OK. 

7	 Using the Type tool, select the “(V, GF)” later in the first paragraph. 

8	 Click Red Italic in the Character Styles panel.

Because you applied a character style instead of a paragraph style, the formatting 
affected only the selected text, not the entire paragraph.

9	 Using the Type tool, select the “(V)” next to “fresh basil pesto” in the text frame 
at the right. 

10	Click Red Italic in the Character Styles panel.

11	Repeat the process to apply the Red Italic character style to the “(V, GF)” and the 
trailing period at the end of the paragraph.  

12	Choose Type > Character Styles to close the panel, and then choose File > Save.

▶▶ Tip:  Typesetters 
often apply the same 
style to any punctuation 
following text formatted 
with a different style. 
(For example, if a word 
is italicized, you would 
italicize a comma after 
it.) This may vary based 
on design preferences 
or a publisher’s style 
guide. The key is to 
be consistent.
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Importing graphics
To add one of the final design elements to the postcard, you’ll import, resize, and 
position a graphic. In InDesign, graphics are placed inside frames, and the Selection 
tool ( ) allows you to resize the graphics frame and to position the graphic 
within the frame. You will learn more about working with graphics in Lesson 11, 
“Importing and Modifying Graphics.”

1	 Choose View > Fit Page In Window. 

You will position the graphic in the upper-right quadrant of the postcard. 

2	 Make sure that no objects are selected by choosing Edit > Deselect All. 

3	 Click the Import File button, the last option on the Properties panel at the right. 
In the Place dialog, make sure that Show Import Options is not selected.

4	 Navigate to the Lesson02 folder in the Lessons folder, and double-click the 
DiningRoom.jpg file.

The loaded graphics icon ( ) displays a preview of the graphic. If you click the 
page, InDesign places the graphic at full size, inside an identically sized graphics 
frame. In this case, however, you will scale the graphic as you add it to the page. 
The resulting graphics frame will have the same dimensions as the graphic. The 
graphic will be placed in the upper-right quadrant of the postcard. 

5	 Position the loaded graphics icon at the intersection of the light blue and  
pink guides as shown. If necessary, consult the finished lesson document,  
02_End.indd, to see where to place the graphic.

6	 Drag down and to the right until the pointer touches the guide on the right side 
of the page.

 

When you release the mouse button, the graphic is added to the page, and 
a graphics frame is created automatically. If the Text To Image bar displays 
automatically, you may ignore it for now. 

You will now experiment with cropping a graphic by decreasing the size of the 
frame, and you will try moving the graphic within the frame. You will undo  
these changes. 

▶▶ Tip:  You can 
place a graphic into 
an existing frame or 
create a new frame as 
you place the graphic. 
You can also drag 
graphic files from your 
computer’s desktop 
onto an InDesign 
page or pasteboard.

▶▶ Tip:  When you 
create a frame while 
placing a graphic on 
the page, the graphic 
is automatically scaled 
to fit within the frame. 
Use the scaling controls 
in the Properties panel 
and the Control panel 
to precisely adjust 
the graphic size. You 
will learn more about 
sizing in Lesson 11.
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7	 Using the Selection tool ( ), select the middle handle at the bottom of the 
graphics frame and drag it up. You can crop the image by dragging any of its 
eight resizing handles.

 

Use the Selection tool 
to crop a graphic by 
reducing the size of 
its frame.

8	 Press Ctrl+Z (Windows) or Command+Z (macOS) to undo the crop.

9	 Still using the Selection tool, position the pointer over the graphic to display 
the content grabber ( ) in the center of the graphic. 

10	Click the content grabber to select the graphic, and then drag up to position 
the image within the frame as you please. 

 

Drag the content 
grabber to position 
the graphic inside  
the frame.

11	Press Ctrl+Z/Command+Z to undo the image move. The eventual position  
of the graphic should be where you placed it in step 6.

12	Choose Edit > Deselect All, and then choose File > Save. 

• Note:  If a video 
displays to explain Text 
To Image or Generative 
Expand, click Got It. 

▶▶ Tip:  To reposition 
a graphic with more 
control, press the 
Shift key while drag-
ging. This constrains 
the movement to 
horizontal, vertical, 
and 45-degree angles. 
Click and pause briefly 
before moving the 
graphic within a frame 
to see the cropped 
part of the graphic 
ghosted but visible 
outside the frame area. Sam
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Adding a graphic with a text prompt
The InDesign Text To Image feature uses artificial intelligence (AI) to generate a 
high-resolution, royalty-free image based on text prompts you enter. The ability to 
generate an image within InDesign is helpful for creating mockups before assigning 
photography or searching a stock photo service. If a project does not require specific 
images, the generated images may be used in final projects as well. In the following 
steps, you will select an existing graphics frame, enter a text prompt, and select from 
the generated images.

1	 The Text To Image feature involves Creative Cloud processing, so be sure the 
computer is connected to the internet during this exercise. 

2	 Zoom in on the lower-right corner of the postcard, where you will see an empty 
graphics frame (indicated by a nonprinting outline and an x inside the frame).

3	 Using the Selection tool ( ), select the graphics  
frame and choose Window > Text To Image. 

4	 In the Prompt field of the Text To Image panel, 
type herbs in pots in the field, and then click 
Generate. (If an alert displays at this point, 
click Agree.) After you click Generate, note the 
following:

•	 The first generated image is placed in the 
graphics frame. Because the graphics frame 
was selected, InDesign generated options to 
work within the frame. 

•	 This AI feature is constantly being fine-tuned based on user feedback. You 
will see different results than those shown here each time you use the feature.

5	 The Text To Image panel opens automatically,  
providing other image options and sizes. 

•	 Click other options in the Variations area of 
the Text To Image panel. If necessary, click 
the arrow next to Variations to view the area.

•	 To see more variations in generated  
images, you can click Generate again or revise 
the text.

6	 Select the image you prefer with the layout. The 
image shown here is not likely to be an option. 

7	 Click Done, and then choose Window > Text  
To Image to close the panel. 

8	 Choose Edit > Deselect All, and then choose File > Save. 
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Working with objects
The building blocks of InDesign pages are objects: text frames, graphics frames, 
lines, and more. In general, you move and resize objects with the Selection tool. 
Objects can have a fill color (background color) and a stroke color (outline or 
border), which you can customize by specifying the width and style. You can move 
objects around freely, snap them to other objects, and place them with precision 
according to guides or values you enter. In addition, you can resize and scale objects 
and specify how text wraps around them. Here, you will experiment with a few 
object-related features, including adding a QR code for easy web access.  

Moving and rotating an object
A flower graphic created by converting flower characters from the Zapf Dingbats 
font into outlines (Type > Create Outlines) was created on the pasteboard to the left 
of the page. You will move this graphic to the right of the restaurant name, “edible 
blossoms.” Then, you will rotate the object and adjust its placement.

1	 Choose View > Fit Page In Window to center the page in the document window. 
Scroll left to see the flower graphic on the pasteboard.

2	 To better focus on the objects, choose Type > Hide Hidden Characters.

3	 Using the Selection tool ( ), click the flower graphic.

4	 Drag the graphic to the right of the headline, “edible blossoms.” 

With the object still selected, you will fine-tune the placement using the 
Properties panel. 

5	 In the Transform controls of the Properties panel, click the More Options 
button ( ) if necessary. To specify the object’s placement in relation to its 
reference point (upper-left corner), type the following values in the fields:

X: 1.85 in

Y: .05 in

Rotation angle ( ): –10

You can tab between the fields, and then press Enter (Windows) or Return 
(macOS) to apply the changes. 

▶▶ Tip:  You will learn 
more about objects  
in Lesson 4, “Working 
with Objects.”

▶▶ Tip:  When you 
enter values in the 
Properties panel or 
Control panel X and 
Y fields, the object is 
repositioned according 
to its reference point. 
You can view and 
change the reference 
point ( ) by clicking a 
box immediately to the 
left of the X and Y fields. 
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6	 Choose File > Save.

Changing an object’s stroke and fill
When an object is selected, you can change its stroke (outline or border) weight and 
color. In addition, you can apply a fill (background) color. 

1	 Choose Edit > Deselect All to make sure nothing is selected. 

2	 Click the Direct Selection tool ( ) on the Tools panel, and then click the white 
flower in the graphic to select it. 

3	 In the Appearance controls of the Properties panel, click the Fill box ( ) to 
display the document’s swatches. Click the Green-Dark swatch.

4	 Press the V key on the keyboard to switch to the Selection tool ( ). Click to 
select the black horizontal line at the bottom of the page. 

5	 In the Appearance controls of the Properties panel, click the Stroke box ( ) 
to display the document’s swatches. Click the Green-Medium swatch.

6	 Click the pasteboard to deselect all objects. 

7	 Choose File > Save.

• Note:  The flower 
graphic is a group of 
objects. The Direct 
Selection tool lets you 
select a single object 
within a group. You 
can also select a single 
object in a group by 
double-clicking it with 
the Selection tool.
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