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146

MASKS AND CHANNELS

Lesson overview
In this lesson, you’ll learn how to do the following: 

• Create a mask to remove a subject from a background. 

• Refine a mask to include complex edges.

• Create a quick mask to make changes to a selected area.

• Edit a mask using the Properties panel.

• Manipulate an image using Puppet Warp. 

• Save a selection as an alpha channel. 

• View a mask using the Channels panel.

• Load a channel as a selection.

• Create a pattern by drawing a star­shaped vector graphic 
with rounded corners.

This lesson will take about an hour to complete. To get the lesson files 
used in this chapter, download them from the web page for this book 
at adobepress.com/PhotoshopCIB2022. For more information, see 
“Accessing the lesson files and Web Edition” in the Getting Started  section 
at the beginning of this book.

As you work on this lesson, you’ll preserve the start files. If you need to 
restore the start files, download them from your Account page. 

6
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Use masks to isolate and manipulate specifi c parts of 
an image. The cutout portion of a mask can be altered, 
but the area surrounding the cutout is protected from 
change. You can create a temporary mask to use once, 
or you can save masks for repeated use. 
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148 LESSON 6 Masks and Channels

Working with masks and channels
When you want to edit a specific area of a layer, it can be difficult to keep edits 
from going past the precise edge you want. Or you might want to apply an adjust­
ment layer or a filter to only part of a layer. Both are easier using a mask, a type of 
image overlay that controls which layer areas will be affected by edits.

You can also use a layer mask to mark transparent areas of a layer. Layer masks are 
essential for removing backgrounds, combining multiple images into a composite 
image, and controlling which areas are affected by adjustment layers. A layer mask 
is more useful than deleting unwanted areas of a layer, because it’s reversible: By 
painting in a layer mask, you can make hidden areas visible again.

In addition to color channels, an image can contain alpha channels, useful for sav­
ing and reusing selections and marking transparent areas for an entire document. 

It can be challenging to paint or draw a mask or channel edge that precisely follows 
a nonsharp border of a subject, such as fuzzy hair. Photoshop provides tools that 
use automation to help you quickly create complicated selections and masks. 

Getting started
First, you’ll view the image that you’ll create using masks and channels. 

1 Start Photoshop, and then simultaneously hold down Ctrl+Alt+Shift (Windows) 
or Command+Option+Shift (macOS) to restore the default preferences. (See 
“Restoring default preferences” on page 5.) 

2 When prompted, click Yes to delete the Adobe Photoshop Settings file.

3 Choose File > Browse In Bridge to open Adobe Bridge.

4 Click the Favorites tab on the left side of the Bridge window. Select the Lessons 
folder, and then double­click the Lesson06 folder in the Content panel. 

5 Study the 06End.psd file. To enlarge the thumbnail so that you can see it more 
clearly, move the thumbnail slider at the bottom of the Bridge window to the right.

In this lesson, you’ll create a graphic for a podcast. The model was photographed 
in front of a different background. You’ll use Select And Mask to quickly isolate the 
model over the final background. You’ll also tilt the model’s head up a little more 
and create a pattern for the background.

6 Double­click the 06Start.psd thumbnail to open it in Photoshop. Click  
OK if you see an Embedded Profile Mismatch dialog box.

7 Choose File > Save As, rename the file to 06Working.psd, and click Save. Click  
OK if the Photoshop Format Options dialog box appears.

Saving a working version of the file lets you return to the original if you need it.

� Tip: The way 
masks work is similar 
to applying masking 
tape to panes or wall 
trim before you paint a 
house: Masked areas are 
protected from being 
changed.

� Note: Masks and 
alpha channels don’t 
print and aren’t visible; 
you see their effects 
only on visible layers.

� Note: If Bridge 
isn’t installed, the 
File > Browse In Bridge 
command in Photoshop 
will start the Creative 
Cloud desktop app, 
which will download 
and install Bridge. After 
installation completes, 
you can start Bridge.

� Note: If Photoshop 
displays a dialog box 
telling you about the 
difference between 
saving to Cloud 
Documents and On Your 
Computer, click Save On 
Your Computer. You can 
also select Don’t Show 
Again, but that setting 
will deselect after 
you reset Photoshop 
preferences.
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Using Select And Mask and Select Subject
Photoshop provides a set of tools focused on creating and refining masks, collected 
in a task space called Select And Mask. Inside Select And Mask, you’ll use the 
Select Subject tool to get a fast head start on the mask that will separate the model 
from the background. Then you’ll refine the mask using other Select And Mask 
tools, such as the Quick Selection tool.

1  In the Layers panel, make sure both layers are visible and the Model layer 
is selected.

2 Choose Select > Select And Mask.

� Tip: Because masks 
mark which areas of a 
layer are visible, they 
also control where your 
edits are visible. For 
example, if you paint a 
masked layer with the 
Brush tool, the brush 
strokes are visible 
only on the unmasked 
(white) areas of a layer.

� Tip: When any 
selection tool is active, 
the Select And Mask 
button is available in 
the options bar. When 
the Select And Mask 
button is not available, 
you can still use the 
Select > Select And 
Mask command.

About masks and alpha channels
Alpha channels, quick masks, clipping masks, layer masks, vector masks— 
what’s the difference? They’re all forms of the same idea: an image overlay that uses 
white, black, and gray areas to control which areas of a layer are visible or transparent. 
Choose the right one by understanding the following important differences:

• A color channel stores one of the visible components of a color image. For 
example, an RGB image has three color channels: red, green, and blue. 

• An alpha channel stores a selection as a grayscale image. Alpha channels exist 
independently of layers and color channels. You can convert alpha channels to 
and from selections or paths. In some file formats such as PNG, an alpha channel 
marks transparent areas of an image in a way that other applications recognize.

• A layer mask is an alpha channel attached to a specific layer in Photoshop, 
controlling which parts of the layer are revealed or hidden. It appears as a white 
thumbnail next to the layer thumbnail in the Layers panel until you paint black 
in it; an outline around the layer mask thumbnail indicates that it’s selected.

• A vector mask is a layer mask made of resolution-independent vector objects, 
not pixels, useful when precise mask edge control is more important than being 
able to edit a mask with a brush. You create vector masks using the commands 
on the Layer > Vector Mask submenu and using the pen or shape tools. 

• A clipping mask is created when a layer masks another layer. The thumbnail 
preview of a clipped layer is indented in the layer list, with a right-angle arrow 
pointing to the layer below. The name of the clipped base layer is underlined.

• A channel mask is a mask created using the tonal contrast in a color channel, 
such as in the green channel in an RGB image. Creating channel masks is useful 
for advanced techniques for masking, color correction, and sharpening. For 
example, the edge between trees and sky may be clearest in the blue channel. 

• A quick mask is a temporary mask you create to restrict painting or other edits 
to a specific area of a layer. It’s a selection in pixel form; instead of editing the 
selection marquee, you edit a quick mask using painting tools.
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150 LESSON 6 Masks and Channels

Select And Mask opens with the image. A semitransparent “onion skin” overlay 
indicates masked areas. For now, the checkerboard pattern covers the entire image, 
because you haven’t yet identified the areas to unmask.

3 Click the View menu in the View Mode section of the Properties panel, and 
choose Overlay. The masked area is now shown as a semitransparent red color 
instead of the onion skin checkerboard. It’s solid because nothing is masked yet.

The different View Modes are provided so that you can see the mask more easily 
over various backgrounds. In this case, the red overlay will make it easier to see 
missed areas and edges where loose hair isn’t properly masked.

� Tip: The first time 
you use Select And 
Mask, a tutorial tip may 
pop up. You may view 
it before you continue 
with the lesson, or you 
can click Later or Close.

� Tip: For more help 
making selections, refer 
to Lesson 3, “Working 
with Selections.”

� Tip: When a 
selection tool is active, 
you can enter Select 
And Mask by clicking 
the Select And Mask 
button in the options 
bar instead of having 
to find the command in 
the menus.

� Tip: Quickly cycle 
through the View 
Modes by pressing the 
F key. Viewing different 
modes helps you spot 
selection mistakes that 
might not be obvious in 
other modes.
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4 In the Options bar, click the Select Subject button.

Using advanced machine learning technology, the Select Subject feature is trained 
to identify typical subjects of a photo, including people, animals, and objects, and 
then create a selection for them. The selection may not be perfect, but it’s often 
close enough for you to refine easily and rapidly with other selection tools.

5 Click the View menu in the View Mode section of the Properties panel, and 
choose Black & White. This View Mode helps make the mask edge easier to see.

6 In the Properties panel, expand the Refine Mode if needed, and click Color 
Aware. If a message appears, click OK. The mask edge changes.

The two Refine Modes interpret potential subject edges differently. Color Aware 
can work well on simple backgrounds like the one in this lesson. Object Aware may 
work better on more complex backgrounds. If you want to compare the two results, 
choose Edit > Toggle Last State to switch between them.

7 Click the View menu in the View Mode section of the Properties panel, and 
choose Overlay to better compare the edge to the actual image.

Notice that there are a few areas over the chest that were missed by Select Subject. 
You can easily add them to the selection using the Quick Selection tool.

8 Make sure the Quick Selection tool ( ) is selected. In the options bar, set up a 
brush with a size of 15 px.

9 Drag the Quick Selection tool over the  
missed areas (without extending into the 
background) to add the missed areas to 
the selection. Notice that the Quick 
Selection tool fills in the selection as it 
detects content edges, so you don’t have 
to be exact. It’s OK if you release the 
mouse button and drag more than once.

� Note: If you don’t 
see the Select Subject 
button in the Select 
And Mask task space, 
make sure the Quick 
Selection tool (the first 
one in the toolbox) is 
selected.

� Tip: You don’t have 
to be in the Select And 
Mask dialog box to use 
the Select > Subject 
command. It’s available 
even when a selection 
tool is not active. Also, 
it’s OK to use Select 
Subject first and then 
enter Select And Mask 
to refine the selection.

� Tip: When editing a 
selection, increase the 
magnification if it helps 
you see missed areas.
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Where you drag teaches the Quick Selection tool which areas should be revealed 
and are not part of the mask. Do not drag the Quick Selection tool over or past the 
model’s edge to the background, because this teaches the Quick Selection tool to 
include part of the background in the mask, and you don’t want that. If you acci­
dentally add unwanted areas to the mask, either choose Edit > Undo or reverse the 
edit by painting over it with the Quick Selection tool in Subtract mode. To enable 
Subtract Mode for the Quick Selection tool, click the Subtract From Selection 
icon ( ) in the options bar.

As you drag the Quick Selection tool over the model, the overlay  disappears from 
the areas that you are marking to be revealed. Don’t worry about total perfection at 
this stage.

10 Click the View menu in the View Mode section again, and choose On Layers. 
Th is shows you how the current Select And Mask settings look over any layers 
that are behind this layer. In this case, you’re previewing how the current settings 
will mask the Model layer over the Episode Background layer.

Inspect the edges around the model at a high magnifi cation, such as 400%. Some of 
the original light background may still show between the model’s edge and the pod­
cast background, but overall the Select Subject and Quick Selection tools should 
have created clean edges for the shirt and face. Don’t be concerned about edge gaps 
or imperfect hair edges, because you’ll take care of those next.

� Tip: You can adjust 
the opacity of the onion 
skin by dragging the 
Transparency slider 
under the View Mode 
options.
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Getting better and faster 
results with Select And Mask
When using Select And Mask, it’s important to use different tools for image areas 
that should be fully revealed, for areas that should be fully masked, and for partially 
masked edges (such as fuzzy dog hair). Try these recommendations:

• The Select Subject button can be a fast way to create an initial selection.

• The Quick Selection tool is useful for rapidly touching up a selection produced 
by Select Subject or for creating an initial selection. As you drag it, it uses edge 
detection technology to find mask edges automatically. Don’t drag it on or over 
a mask edge; keep it fully inside (in Add mode) or outside (in Subtract mode) the 
areas that should be revealed.

• To paint or draw solid mask edges manually (without using any automatic 
edge detection), use the Brush, Lasso, or Polygonal Lasso tool. These also have 
an Add mode for marking revealed areas and a Subtract mode for marking 
masked areas.

• Instead of having to switch between Add and Subtract modes with the toolbar, 
you can leave a tool in Add mode, and when you want to temporarily use the 
tool in Subtract mode, hold down the Alt (Windows) or Option (macOS) key.

• To improve the mask along edges containing complex transitions such as hair, 
drag the Refine Edge Brush along those edges. Do not drag the Refine Edge 
brush over areas that should be fully revealed or fully masked.

• You don’t have to do all of your selecting inside Select And Mask. For example, if 
you’ve already created a selection with another tool such as Color Range, leave 
that selection active, and then click Select > Select And Mask in the options bar 
to clean up the mask.

Refining a mask
The mask is pretty good so far, but Select Subject 
didn’t quite capture all of the model’s hair. For 
example, some of the strands coming off of 
the bun on the back of the model’s head are 
discontinuous. In Select And Mask, the Refine 
Edge Brush tool is designed to mask edges with 
challenging details.

1 At a magnification of 300% or higher, inspect 
the hair edges at the back of the model’s head.

� Tip: In Select And 
Mask, the Polygonal 
Lasso tool is grouped 
with the Lasso tool.

Sam
ple

 p
ag

es



154 LESSON 6 Masks and Channels

2 Select the Refine Edge Brush 
tool ( ). In the options bar, set 
up a brush with a size of 20 px 
and Hardness of 100%.

3 Drag the Refine Edge Brush tool 
between the hair bun and the ends of 
the hair, where the selection needs to 
be improved. As you drag the Refine 
Edge Brush tool over the hair edge, 
you should see that the missing hair 
strands falling from the bun are now 
included in the visible areas.

4 Scroll down to the loop of hair that falls over the back of the shirt.

Select Subject correctly masked the background inside the hair loop. However, a 
more subtle hole above still needs to reveal the podcast background, so you’ll use 
the Refine Edge Brush to add that hole to the mask.

5 In the options bar, set up a Refine Edge brush with a size of 15 px, with a 
Hardness of 100%.

� Tip: If you use a 
tool to make the initial 
selection (instead of 
Select Subject), click 
the Refine Hair button. 
It should result in 
less manual brushing 
with the Refine Edge 
Brush tool.
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Julieanne Kost is an offi  cial Adobe Photoshop evangelist. 

Tool tips from the Photoshop 
evangelist
Zoom tool shortcuts

Often when editing an image, you’ll need to zoom in to work on a detail and then 
zoom out again to see the changes in context. Here are several keyboard shortcuts 
that make zooming faster and easier.

• With any tool selected, press Ctrl (Windows) or Command (macOS) with the plus 
sign (+) to zoom in, or with the minus sign (−) to zoom out.

• Double-click the Zoom tool in the Tools panel to return the image to 100% view.

• When Scrubby Zoom is selected in the options bar, just drag the Zoom tool to 
the left to zoom out or to the right to zoom in.

• Press Alt (Windows) or Option (macOS) to change the Zoom In tool to the Zoom 
Out tool, and click the image. Each Alt/Option-click reduces the image by the 
next preset increment, centering the image where you clicked.

6 Drag the Refi ne Edge Brush tool over the enclosed area that should be 
transparent. Gaps in the hair should become masked as transparent, and fi ne 
hairs are added to the visible edge.
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7 Click the View option, and choose Black & White. This is another good way to 
check your mask. Inspect the mask at different magnifications, and when you’re 
done, choose View > Fit On Screen. Black areas indicate transparency.

If you see hairs or other details that are masked but should be visible, drag the 
Refine Edge brush over them. The finer the details you want to mask, the smaller 
you should set the Refine Edge brush size. It’s OK if the brush size is slightly larger 
than the details you want to mask, and you don’t have to drag the Refine Edge 
Brush tool precisely.

If you see Refine Edge Brush tool mistakes that need to be erased, such as inner 
areas incorrectly added to the mask, drag the Refine Edge Brush tool over the mis­
takes while holding down the Alt (Windows) or Option (macOS) key.

If you see individual spots or discrete areas that need to be fully visible or fully 
transparent, you can paint them out using the Brush tool, the third one down in the 
toolbox. To make areas visible, paint them with white; to make areas hidden, paint 
them with black.

� Tip: Gray pixels 
should appear only in 
transitional edges of 
a mask. All areas fully 
outside the subject 
should be solid black, 
and all areas fully inside 
should be solid white.

� Tip: A quick way to 
remember what color 
to paint in a mask is the 
phrase “black conceals, 
white reveals.”
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Adjusting Global Refinements
At this point the mask is in good shape, but needs to be tightened up a little. 
You can tune the overall appearance of the mask edge by adjusting the Global 
Refinements settings.

1 Click the View menu in the View Mode section of the Properties panel, 
and choose On Layers. This lets you preview adjustments over the Episode 
Background layer, which is behind the Model layer.

2 In the Global Refinements section, move the sliders to create a smooth, 
unfeathered edge along the face. The optimal settings depend on the 
selection you created, but they’ll probably be similar to ours. We moved the 
Smooth slider to 1 to reduce the roughness of the outline, Contrast to 20% to 
sharpen the transitions along the selection border, and Shift Edge to −15% to 
move the selection border inward and help remove unwanted background 
colors from selection edges. (Adjusting Shift Edge to a positive number would 
move the border outward.)

3 Take one more look at this preview of the current mask over the background 
layer, and make any remaining corrections as needed.

� Note: Pay attention 
to details while using 
Global Refinements. For 
example, if you adjust 
Smooth and the mask 
edge starts to round 
corners or grind down 
important details, that 
means Smooth is set 
too high. Similarly, 
setting Feather too high 
can create unsightly 
halos along the edge.
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Completing the mask
When you’re satisfi ed with the mask preview, you can create its fi nal output as 
a selection, a layer with transparency, a layer mask, or a new document. For this 
project, we want to use this as a layer mask on the Model layer, which was selected 
when you entered Select And Mask.

1 If the Output Settings are hidden, click the disclosure icon ( ) to reveal them.

2 Zoom in to 200% or more so that you can more easily see the light fringing 
around the face edge that’s due to the Model layer’s original background color 
seeping in behind the mask.

3 Select Decontaminate Colors to suppress those color fringes. If Decontaminate 
Colors creates unwanted artifacts, reduce the Amount until the eff ect looks the 
way you want. We set Amount to 25%.

� Tip: If you mask 
many images that need 
similar settings, click 
the Preset menu and 
choose Save Preset to 
create a named preset 
of Select and Mask 
properties that you can 
apply at any time.
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4 Choose New Layer With Layer Mask from the Output To menu. Then click OK.

Clicking OK exits Select And Mask. In the Layers panel, the Model Copy layer now 
has a layer mask (pixel mask) that was generated by Select And Mask.

The layer was copied because using the Decontaminate Colors option requires 
 generating new pixels. The original Model layer is preserved and automatically 
 hidden. If you wanted to start over, you could delete the Model Copy layer, make the 
 original Model layer visible again and selected, and open Select And Mask again.

If the mask isn’t perfect, you can continue to edit it at any time. When a layer mask 
thumbnail is selected in the Layers panel, you can click the Select And Mask button 
in the Properties panel, click it in the options bar (if a selection tool is active), or 
choose Select > Select And Mask.

5 Save your work.

� Note: If you had not 
selected Decontaminate 
Colors, it would have 
been possible to choose 
a Layer Mask output 
option that would have 
added a layer mask to 
the Model layer without 
copying it.
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Creating a quick mask
To change the color of the glasses frames, you’ll use a quick mask, because you 
won’t need the mask after you’re done with this one task and so that you can create 
the mask by painting. First, you’ll clean up the Layers panel.

1 Hide the Episode Background layer so you can concentrate on the model. Make 
sure the Model copy layer is selected.

2 Click the Edit In Quick Mask Mode button near the bottom of the Tools panel. 
(Until now, you have been working in the default Standard mode.)

In Quick Mask mode, a red overlay appears as you make a selection, masking the 
area outside the selection the way a rubylith, or red acetate, was used to mask images 
in traditional print shops. (This idea is similar to the Overlay view mode you saw in 
Select And Mask.) You can apply changes only to the unprotected area that is visible 
and selected. Notice that the highlight color for the selected layer in the Layers 
panel is red, indicating you’re in Quick Mask mode. 

3 In the Tools panel, select the Brush tool ( ). 

4 In the options bar, make sure that the mode is Normal. Open the Brush 
pop­up panel, and select a small brush with a diameter of 13 px and a 
Hardness of 100%. Click outside the panel to close it.

5 Paint the earpiece of the glasses frames. (Magnify the view if it helps you paint more 
precisely.) The area you paint will appear red, creating a mask. 

� Note: If you are 
using a small display 
and the Tools panel is 
in single-column mode, 
the Quick Mask Mode 
button may be past the 
bottom of the screen. 
If the Tools panel is in 
two-column mode, 
the Quick Mask Mode 
button is at the bottom 
left corner of the panel. Sam
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6 Continue painting with the Brush tool to mask the earpiece of the frames and 
the frame around the lenses. Reduce the brush size to paint around the lenses. 
You can stop where the earpiece goes under the hair.

In Quick Mask mode, Photoshop treats the red overlay as a grayscale mask, where 
shades of gray correspond to degrees of mask transparency. When using a painting 
or editing tool in Quick Mask mode, keep these principles in mind:

• Painting with black adds to the mask (the red overlay), subtracting from the 
selected area.

• Painting with white erases the mask, adding to the selected area.

• Painting with gray or reduced opacity adds semitransparent areas to the 
mask, where darker shades are more transparent (more masked). 

7 Click the Edit In Standard Mode button ( ), which is the same as the Enter 
Quick Mask Mode button.

Exiting Quick Mask mode converts the Quick Mask into a selection.

8 Choose Select > Inverse to select the area you originally masked.

9 Choose Image > Adjustments > Hue/Saturation. Th e selection is converted to a 
layer mask that restricts the Hue/Saturation adjustment to the unmasked area.

10 In the Hue/Saturation dialog box, change the Hue to +70. Th e new green color 
fi lls the glasses frame. Click OK.

11 Choose Select > Deselect.

� Tip: Here, you’re 
making a selection by 
painting the area you 
want to select. Compare 
this to Chapter 3, where 
you made selections 
using tools that create a 
selection marquee.

� Tip: If you want 
to keep the selection 
for future use, save it 
as an alpha channel 
(Select > Save Selection); 
otherwise, it will be lost 
as soon as the area is 
deselected.
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Manipulating an image with Puppet Warp
Th e Puppet Warp feature gives you fl exibility in manipulating an image. You can 
reposition areas, such as hair or an arm, just as you might pull the strings on a 
puppet. Place pins wherever you want to control movement. You’ll use Puppet 
Warp to tilt the model’s head back so she appears to be looking up.

1 Zoom out so you can see the entire model.

2 With the Model Copy layer selected 
in the Layers panel, choose Edit > 
Puppet Warp.

A mesh appears over the visible areas 
in the layer—in this case, the mesh 
appears over the model. You’ll use the 
mesh to place pins where you want to 
control movement (or to ensure there 
is no movement).

3 Click to add pins around the body 
and along the base of the head, as 
shown below. Each time you click, 
Puppet Warp adds a pin. About 10 
to 12 pins should work.

Th e pins you’ve added around the shirt will keep it in place as you tilt the head.

4 Select the pin at the nape of the neck. A blue dot appears in the center of 
the pin to indicate that it’s selected.

� Note: Photoshop 
provides several 
diff erent ways to warp a 
layer. You’ll use Puppet 
Warp because it’s the 
easiest way to pivot 
part of an image, such 
as tilting the head back 
in this example.
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5 Press Alt (Windows) or Option 
(macOS). A larger circle appears 
around the pin, and a curved double 
arrow appears next to it. Continue 
pressing Alt or Option as you 
drag the pointer to rotate the head 
backwards. You can see the angle 
of rotation in the options bar; you 
can enter 170 there to rotate the 
head back. 

6 When you’re satisfi ed with the 
rotation, click the Commit Puppet 
Warp button ( ) in the options bar, 
or press Enter or Return.

7 Save your work so far.

Using an alpha channel to create a shadow
Just as diff erent information in an image is stored on diff erent layers, channels also let 
you access specifi c kinds of information. Alpha channels store selections as grayscale 
images. Color information channels store information about each color in an image; 
for example, an RGB image automatically has red, green, blue, and composite channels.

To avoid confusing channels and layers, think of channels as containing an image’s 
color and selection information, and think of layers as containing painting, shapes, 
text, and other content.

� Note: Be careful not 
to Alt-click or Option-
click the dot itself, or 
you’ll delete the pin. 
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